So let’s talk about how to resolve the error “Warning: CocoaPods is installed but broken. Skipping pod install. You appear to have CocoaPods installed but it is not working.” which comes when you try to run flutter commands.

Warning: CocoaPods is installed but broken

If you get this error, simply run the command below which resolves your issue.

If you’re using Linux or MacOS, open a terminal/shell window and run the command below.

$ sudo gem install cocoapods

If you’re using Windows, run the command below with Command prompt. Make sure to open your CMD with Admin permissions.

$ gem install cocoapods

That’s all 🙂